We want your feedback: take the 2023 annual survey and help us improve napari for you and the community!

napari-locan

napari-locan

Use locan methods in napari for single-molecule localization microscopy data.

License napari hub PyPI Conda (channel only) Python Version tests Code style: black codecov Documentation Status

Load, visualize and analyze single-molecule localization microscopy (SMLM) data.

napari-locan is a napari plugin that implements a subset of methods from locan, a python-based library with code for analyzing SMLM data. Locan provides extended functionality that is better suited for script- or notebook-based analysis procedures. napari-locan is well suited for exploratory data analysis within napari.

For details on usage and development of napari-locan please read the documentation.

Installation

Make sure to have Qt bindings installed in your python environment of choice.

You can install napari-locan from PyPI:

pip install napari-locan

or from conda-forge:

mamba install -c conda-forge napari-locan

Please read the documentation on installation for more details.

Usage

Please read the documentation for details.

Contributing

Contributions are very welcome. Please read the documentation on development for details.

Credit

The plugin was developed in the Department of Biotechnology and Biophysics, Würzburg University, Germany. It is based on locan. So credit goes to the locan developers and can be cited.

License

Distributed under the terms of the BSD-3 license, "napari-locan" is free and open source software. See the LICENSE file for details.

Issues

If you encounter any problems, please file an issue along with a detailed description.


This napari plugin was generated with Cookiecutter using @napari's cookiecutter-napari-plugin template.

Version:

  • 0.5.0

Last updated:

  • 07 December 2023

First released:

  • 29 October 2023

License:

Supported data:

  • Information not submitted

Plugin type:

GitHub activity:

  • Stars: 1
  • Forks: 0
  • Issues + PRs: 0

Python versions supported:

Operating system:

Requirements:

  • locan >=0.18
  • matplotlib
  • napari
  • napari-matplotlib
  • numpy
  • qtpy

Sign up to receive updates