grabber-ift

grabber-ift

A tool for contour-based segmentation correction (2D only).


    View project data

    Learn more:

    • Documentation
    • Support site
    • Report issues

    Source code:

    • Information not submitted

    License PyPI Python Version tests codecov

    A tool for contour-based segmentation correction (2D only).

    This repository provides a demo code of the paper:

    Grabber: A Tool to Improve Convergence in Interactive Image Segmentation Jordão Bragantini, Bruno Moura, Alexandre X. Falcão, Fábio A. M. Cappabianco


    This napari plugin was generated with Cookiecutter using with @napari's cookiecutter-napari-plugin template.

    Installation

    You can install grabber-ift via pip:

    pip install grabber-ift

    Known Limitations

    This implementation doesn't support the items below, feel free to open a PR to add them.

    • It only support 2D image, supporting 3D images isn't trivial, but it could be applied per slice with minor changes.

    Citation

    If this work was useful for your research, please cite our paper:

    @article{bragantini2020grabber,
      title={Grabber: A Tool to Improve Convergence in Interactive Image Segmentation,
      author={Bragantini, Jord{\~a}o and Bruno Moura, Falc{\~a}o, Alexandre Xavier and Cappabianco, F{\'a}bio AM,
      journal={Pattern Recognition Letters},
      year={2020}
    }

    Contributing

    Contributions are very welcome. Tests can be run with tox, please ensure the coverage at least stays the same before you submit a pull request.

    License

    Distributed under the terms of the MIT license, "grabber" is free and open source software

    Issues

    If you encounter any problems, please [file an issue] along with a detailed description.

    Version:

    • 0.2.2

    Release date:

    • 14 December 2021

    First released:

    • 12 December 2021

    License:

    • MIT

    Supported data:

    • Information not submitted

    Plugin type:

    GitHub activity:

    • Stars: 0
    • Forks: 0
    • Issues + PRs: 0

    Python versions supported:

    Operating system:

    Requirements:

    • napari-plugin-engine (>=0.1.4)
    • pyift (>=0.0.4)
    • opencv-python-headless (>=4.4.0)
    • scipy (>=1.7.2)

    Sign up to receive updates